PHP is amongst the most commonly used server-side coding languages. It’s very popular since it’s free software, which you can use to develop interactive sites like community websites, online shops or online teaching portals rather than static HTML sites. A PHP module should be available on the server where a PHP-powered website is hosted so that its PHP code can be ‘decrypted’. Because there are no license taxes for this kind of module and the language offers incalculable possibilities for the web applications that you develop, there are hundreds of millions of PHP websites. Besides, there are loads of open-source PHP scripts, which you can use for your websites without having to possess any coding capabilities. Considering the fact that there’re a handful of versions of PHP, you ought to ensure that the same exact version that you used whilst building your website is enabled on the server as well.

PHP 4, PHP 5 and PHP 7 Support in Web Hosting

Our web hosting servers support different PHP versions, which goes to say that your websites will work flawlessly even if your PHP scripts are outdated. We accept the fact that an old website doesn’t automatically mean a vulnerable one as you may have done plenty of mods to its source code. This is the reason why we support PHP 4, PHP 5 and PHP 7 and you can decide which one will be active for your hosting account. The version can be changed with one click of the mouse from your Hepsia hosting Control Panel and the new settings will take effect instantaneously. If you would like to run both older and newer scripts, there is even an option to use a different PHP version for each domain name of yours simultaneously.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

We’re steadfast in our opinion that several years spent setting up a site shouldn’t be in vain, so if you purchase a semi-dedicated server from us, you will be able to run any script, no matter if it is old or new. In contrast with lots of hosting companies, we support several different versions of PHP on our cutting-edge cloud hosting platform – 4, 5 and 7. You will not only be able to activate the required version through your Hepsia Control Panel, but you’ll also have the opportunity to specify a different PHP version for each single website. This can be accomplished merely by inserting an .htaccess file into the given site’s root directory. You can change the current version both for a single site and for the account itself and the change will be applied in no more than a couple of minutes. With our web hosting services, you can be certain that you won’t ever confront any website incompatibility challenges.